Es passiert, dass das Monitoring intern mit einem Timeout abbricht und so der Prozessstatus nicht ermittelt werden kann. 


Ursache

Durch den Abbruch erhält der Sensor nicht alle nötigen Daten. Fehlen Prozesse in der Erfassung, so werden diese als "not running" gekennzeichnet, da ihr Status durch den Timeout unbekannt ist. Der Sensor kann das Fehlen von Prozessinformationen von einem nicht laufenden Prozess nicht unterscheiden. Problem ist der Zeitdienst-Service der Starface, der die Systemzeit der Starface mit einem externen Zeitserver synchronisiert. Hierbei wird das Linux Paket ntp-4.2.6p5 verwendet, dessen Konfiguration fehlerhaft ist und dafür sorgt, dass die Zeitsynchronisation mit einem Timeout fehlschlägt. Solange dieser Timeout nicht erreicht ist verzögert sich die Datenausgabe, die der Sensor zur Verarbeitung verwendet. 


Lösung

  • Verbinden Sie sich als root-User mit der Starface-Installation.
  • Editieren Sie die Datei /etc/ntp.conf und ändern Sie die Zeile restrict 127.0.0.1 in restrict localhost um.
  • Speichern Sie die Änderungen und starten Sie den NTP-Dienst neu: /etc/init.d/ntpd restart


Dieses Problem wird voraussichtlich mit Version 6.5 der Starface behoben. Dieses Update erscheint voraussichtlich Mitte April 2018.

 

Weitere Informationen hierzu finden Sie in der Knowledgebase von Fluxpunkt unter folgender Beitrags-Quelle: https://wiki.fluxpunkt.de/pages/viewpage.action?pageId=33226935