Beschreibung:

Im Taskmanager ist zu sehen, dass der Prozess MasterAgentContainerService.exe eine ungewöhnlich hohe CPU Auslastung aufweist (~20 %). Nach dem Neustart des Dienstes ist es kurz besser aber die Auslastung steigt wieder.

In den Logs ist Folgendes zu sehen:

21.07.27 16:48:22 ERROR ServerEye.Client.Controller.ClientContainer.ClientContainerCommunicator - sendData: error calling function
OpenSource.UPnP.UPnPInvokeException: Could not connect to device
   bei OpenSource.UPnP.UPnPService.InvokeSync(String MethodName, UPnPArgument[] InVarArr)
   bei ServerEye.Client.UPnP.Connector.CpSensorhubService.Sync_sendData(String guid, String data)
   bei ServerEye.Client.Controller.ClientContainer.ClientContainerCommunicator.sendData(String method, Dictionary`2 data)
21.07.27 16:48:22 ERROR ServerEye.Client.Controller.ClientContainer.ClientContainerCommunicator - sendData: inner exception
21.07.27 16:48:22 ERROR ServerEye.Client.Controller.ClientContainer.ClientContainerCommunicator - sendData: custom exception 


Ursache:

Die Ursache hierfür ist das der OCC-Connector nicht per UPnP an einen Sensorhub senden kann. Das macht er aber auch nur bei sehr alten Sensorhubs. Seit ein paar Jahren laden die Sensorhubs nur noch vom OCC Connector runter.
Also kann es ein Sensorhub sein, der im OCC gelöscht wurde aber beim Kunden noch mit einer vorhandenen sehr alten Server-Eye Installation wieder in Betrieb genommen wurde. Das kann geprüft werden in dem man beim Kunden über unser Toolkit das Tool "DeviceSpy" ausführt und im Netz den alten Sensorhub sucht.